Welcome! If this is your first visit, you will need to register to participate.

DO NOT use symbols in usernames. Doing so will result in an inability to sign in & post!

If you cannot sign in or post, please visit our vBulletin Talk section for answers to vBulletin related FAQs.

Announcement

Collapse
No announcement yet.

TD 12 triggering wrong sounds!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Stix2skin
    replied
    I've been having similar problems, after following various threads on here where the same type of problems were noted I found a posted answer suggesting a battery change could be the fix! indeed for the guy posting his problems and myself this was the answer. Its a fairly easy deal there is also a video on youtube on how to change the battery on a TD20 but its the same deal with a 12. Just be sure to have saved all your settings and editing on your PC or Midi device as these will be wiped when you remove your old battery. Unfortunately I have had a very quick succession of batteries that have died so I think I have other problems too ;(

    Leave a comment:


  • gmeakin
    replied
    update - factory reset didn't work. All leads are fine. Pads work perfectly in TD 11 kit. have cleaned inside sockets with contact cleaner spray. Nothing seems loose or broken...

    Leave a comment:


  • gmeakin
    replied
    thanks for that - is there anyway of uploading videos on here?

    Leave a comment:


  • Tazed
    replied
    Hi Greg, I think I answered your question to some degree through FaceBook (Jeremy, Drummerspeak)!
    But this is the other place to ask more knowledgeable people than myself.
    Go through the steps I suggested and see if that helps, if not, let's bash it out here!

    Leave a comment:


  • gmeakin
    replied
    Thanks for the welcome! Yes it happens on all kits! Not quite sure what you mean by note assignments.....but am going to try a reset today! Cheers

    Leave a comment:


  • hairmetal-81
    replied
    Welcome to the forum, gmeakin!

    Does this happen on all kits in the TD-12?
    Have you checked the note-assignments, or:
    Have you tried doing a module reset?


    HTH

    Leave a comment:


  • gmeakin
    replied
    oh yeah, and x stick sounds on snare are all wack as well, have turned them off. Seems like things have slowly been getting worse on it - over a period of 6 months. Has been suggested to do a factory reset...might try that as a first go...cheers from a first poster!

    Leave a comment:


  • gmeakin
    started a topic TD 12 triggering wrong sounds!

    TD 12 triggering wrong sounds!

    hmm so my Roland TD 12 has decided to start to doing all sorts of weird and not so wonderful things - like the hi hat sensor (the one played by left foot) is triggering off the snare and floor tom...and the ride edge is triggering off a snare rim shot...this when the snare and floor tom are not even plugged in....not sure if its the insert sleeves that need replacing *have had this done on cymbals before as they were self choking, or module issues, or sensor/trigger problems....any advice from fellow electric kit players!? (don't say "go buy a real drum kit"!! Got that and love it!
    cheers
Working...
X