Welcome! If this is your first visit, you will need to register to participate.

DO NOT use symbols in usernames. Doing so will result in an inability to sign in & post!

If you cannot sign in or post, please visit our Forum Talk section for answers to frequently asked questions.

Announcement

Collapse
No announcement yet.

Pulled TDW-20 Expansion card out and sold, now getting error

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Pulled TDW-20 Expansion card out and sold, now getting error

    I called Roland last week to make sure my TD-20 would still work after pulling the TDW expansion card. Well, it doesn't. And I sold the card. Roland rep(nice guy) told me I would have to reload the original firmware (I think FW1.09), and then it will work like it did before the TDW upgrade. I loaded V1.09 on a 512mb FC and when powering the TD-20 I still get the 'Error' message.
    Please, how do I get the original FW loaded so it will work like it did originally?

  • #2
    There is a sticky thread with the step by step instructions. Here is the link: http://www.vdrums.com/forum/advanced...xpansion-board

    -SD-

    Comment


    • #3
      Did you copy the V1.09 update files “TD20UPD.PRG” and “TD20UPD.ROM” on to the root directory of the Compact Flash card?

      If these files are placed in the "Roland" folder the restore will not work.

      See the following "how to" that was originally posted in 2009.

      http://www.vdrums.com/forum/advanced...848#post556848

      --Thanks SiliconDrummer! You were obviously posting the sticky link as I was fumbling for my glasses !


      NOTE: Due to the recent update of RolandUS.com website, the TD-20 V1.09 download is now available at the following link:

      http://www.rolandus.com/products/td-20/downloads/
      Last edited by Guest_User_DA; 03-28-15, 12:51 AM.

      Comment


      • #4
        Thanks guys, still locked on "Error No Expansion Board". I can't get to any other screen, I've tried starting it up with the flash card, a blank CF, CF with 'Roland File' in it, and PRG and ROM files as well, none of those options got me past the Error page. Are there any solutions to get me past that Error page?
        Thanks so much.
        Rich

        Comment


        • #5
          where on the CF card are you putting the PRG and ROM files?

          Comment


          • #6
            Thanks, but still no success. When I put just the PRG & ROM files on the card and turn on the TD-20, the screen is blank, still lit but completely blank. I can't find a 'root directory on the CF card, but the 2 files are the first and only things on the card. Do I need to create a proper root directory?
            Any other advice to get FW 1.09 loaded?
            Thanks!

            Comment


            • #7
              Both Silicon Drummer and myself have asked the same question. The location where the PRG and ROM files are placed on the card is critical for success.

              Secondly, did you read the step by step instruction post that SD and I l provided a link to??

              http://www.vdrums.com/forum/advanced...848#post556848

              Also you indicated "I've tried starting it up with the flash card, a blank CF". Read and follow Step #1 and #4 in the link:

              1) Format the Compact Flash Card on the TD-20. Insert a Compact Flash card into the Compact Flash card slot on the TD-20’s front panel. Press [CARD]. Press [F4 (FORMAT)]. Press [F5 (EXECUTE)]. Press [F5 (EXECUTE)] again to start formatting.

              4) Insert the TD-20 Compact Flash card you just formatted in a Compact Flash reader/writer connected to the computer. Copy the update files “TD20UPD.PRG” and “TD20UPD.ROM” on to the root directory (folder) of the Compact Flash card. Do NOT place them in the "Roland" folder. Unmount (eject) the CF card when completed.
              Last edited by Guest_User_DA; 03-28-15, 01:04 PM.

              Comment


              • #8
                Thanks again for helping me get through this. Sorry I didn't explain in detail before, but when I insert the CF card into the front of the TD-20 to perform the format, the screen is blank and there's nothing I can do (or press) get anything to show up on the screen. Are you saying press F4, then F5, then F5 again blindly? Or should I see text on the TD-20 's display? I tried two different blank CF cards with no success, still blank screen. I have to still be missing something, but what?
                Seriously, Thank You so much for you're quick responses.
                Feel free to call me as well if that's easier.
                Rich
                636-226-4403

                Comment


                • #9
                  Since my problem seems to be the inability to Format via the CF card, is there any button I need to push or hold when starting up an unformatted TD-20 to get it to show formatting options ("card,F4,F5")?

                  Comment


                  • #10
                    Got it! Found an old 512mb CF card, loaded it and worked like a charm. The other 512 card was the problem, the other CF card I tried was 64Gigs which I bet was too large for the TD-20 to read.
                    Thanks so much for all the help!
                    Case Closed successfully!

                    Comment


                    • #11
                      Great news! Happy you got it sorted out.

                      Comment

                      Working...
                      X