Welcome! If this is your first visit, you will need to register to participate.

DO NOT use symbols in usernames. Doing so will result in an inability to sign in & post!

If you cannot sign in or post, please visit our Forum Talk section for answers to frequently asked questions.

Announcement

Collapse
No announcement yet.

Setting up TD30 with SD 2.3.2 I have 2 questions.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Setting up TD30 with SD 2.3.2 I have 2 questions.

    Hi Guys,

    I'm looking for some guidance here. I just bought SD2 and installed OK on my MacBook Pro, set up the TD30 Drivers OK, linked the Midi In and Out OK and the test button proves it's all connected through USB, so far so good.
    On the Video on the Toontrack website about using Edrums to trigger SD samples they talk about turning off local sounds on the TD30, which makes sense, but can someone tell me how you do that? I have googled turning local off on TD30 but found no instructions of how to do this, nor have I found the info in the manual.

    Secondly on the Midi Global settings on the TD30, the soft thru Midi In and USB Midi are set to off. Presumably I need to set soft thru USB Midi from "off" to "Midi Out" and leave soft thru Midi as off (as I am only connecting to computer via USB.

    Thanks in advance for any help you can give.

    Regards

    Russ
    TD30KV, Porter & Davies BC2, QSC KSUB, 2x QSC K12's

  • #2
    Hi,
    If you go to the Roland site and download the pdf of the manual you can do a "find" for any term in that electronic document. (From a Mac I simply do a "command F). I did this and found that the Local Control option is on p. 142 of the manual.

    Also, as a recommendation you don't need (and should not have) both the USB MIDI and MIDI In/Out connections at the same time. Use either/or, but not both at the same time. I recommend using just the USB MIDI for connecting to a computer.

    Lastly, you also don't need a separate digital converter box to generate sound from your VST. That's available inside the TD-30. It actually acts as a digital/audio sound generator itself. In your DAW (GarageBand for example) once the TD-30 is connected it will be available as a sound source. Chose the TD-30 and all the sounds being generated by your computer such as Superior Drummer are sent digitally to the TD-30 and are then converted to analog sound signals and are output out the TD-30 audio outputs. This is the best of both worlds for speed and fidelity. It's almost like having your computer inside the TD-30 - at least as close as it gets.

    Good luck!
    ATV aDrums & aD5, Pearl Mimic Pro & DIY, eDRUMin 10, Agean R-series Silent Cymbals, Roland Handsonic HPD-20.

    Comment


    • #3
      Thanks jpsquared482 for your reply.

      I have found the local control and set it to off.
      I have set USB Midi to "On".
      On the mapping in SD2 I have set it to the preset of Edrums/Roland. I expected that I had now done all I needed, but when I hit the pads there is nothing, no sound, and no sign of toontrack solo recognising the pad has been hit.
      Is there something else I need to do first?
      From the video on Toontrack site it seems there is nothing else to do.
      I am running OSX 10.9 I installed latest driver from Roland site and set up as per instruction, and test button shows all ok.
      I must have to do something else, but I cannot find out what else to do.
      I just thought once I had mapped to Roland Edrums I would be able to play all the SD2 sounds through my TD30 brain.

      If you can help I would be really grateful.

      Thanks

      Russ
      TD30KV, Porter & Davies BC2, QSC KSUB, 2x QSC K12's

      Comment


      • #4
        Forget my last post, I've got it working!!!
        I hadn't set Options for Audio in Toontrack to Audio Device TD30. I also made sure in Options that Midi Device was set to TD30.
        Now it's all working. The only thing I immediately noticed was there is definitely some latency from hitting the pad to getting the sound. it's only a tiny amount, but it is noticeable. I need to learn about latency settings.
        Cheers

        Russ
        TD30KV, Porter & Davies BC2, QSC KSUB, 2x QSC K12's

        Comment


        • #5
          Hi Russ,
          To reduce latency in SD:
          Close all all other applications running on your computer except for your host. (Any open applications can drain your CPU of speed, and you need everything off for the best performance of your host and SD)
          Go to the "Help" icon in the top of the window and search for "latency" It will direct you to the buffer size setting. Try the lowest setting that doesn't affect performance of SD.
          That should do it!
          ATV aDrums & aD5, Pearl Mimic Pro & DIY, eDRUMin 10, Agean R-series Silent Cymbals, Roland Handsonic HPD-20.

          Comment

          Working...
          X