Welcome! If this is your first visit, you will need to register to participate.

DO NOT use symbols in usernames. Doing so will result in an inability to sign in & post!

If you cannot sign in or post, please visit our vBulletin Talk section for answers to vBulletin related FAQs.

Announcement

Collapse
No announcement yet.

MIDI/EZDrummer/Reaper "volume" problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • MIDI/EZDrummer/Reaper "volume" problem

    I was hoping someone might be able to chime in on this as I am a bit at a loss.

    What I am working with:
    Roland TD-12
    eDrum MIDI Mapper
    m-audio uno USB cable
    EZDrummer
    Reaper
    m-audio Axiom 49 keyboard
    Dell P4 3.2Ghz, 4G RAM
    Line 6 UX-2 soundcard
    Line 6's version of ASIO

    When I trigger EZDrummer in Reaper using the pads on the Axiom 49 I get much higher volume sounds within Reaper and than when I trigger using MIDI from my TD-12 kit.

    I hadn't previously noticed this until I decided yesterday to burn the day laying down a song that included keys. Decided to go without drums on this one.

    Anyone have a solution to this, i.e. a volume knob (jk) on the Uno? The volume I have setup in Reaper is the same for the keyboard as the Uno/TD12.

    Thanks in advance!
    Last edited by tripp2k; 07-09-08, 11:02 PM.
    Yamaha Birch Custom Absolute | Zildjian Ks

  • #2
    Bump for some knowledge. I also have a ticket in with m-audio. May just pick up one of the newer Edirol 1x1s VEX-Alan recommends.
    Yamaha Birch Custom Absolute | Zildjian Ks

    Comment


    • #3
      I'm no expert. But troubleshooting is a process of elimination. It appears your MIDI hardware is the same. Your VSTi is the same. So that would indicate a difference between the Axiom and Roland, or the e-drum MIDI mapper assuming you're using different maps for the Axiom and Roland module. So I'd start my investigation on with those three pieces of the puzzle.

      Maybe the Roland is outputting low MIDI velocity, or the MIDI Mapper is killing the velocity?

      * Open Reaper
      * Double-click your track with MIDI
      * It opens the piano roll
      * Scroll horizontally to a section that has notes played via MIDI
      * Note the bottom most section of the view has the velocity information displayed. As an aside you can select any data you want via the pick list at the bottom left corner.
      * The velocity is indicated by a horizontal bar. Shorter bars = quieter notes, bars that reach the top = maximum volume notes

      I'd compare the two differing tracks in question to see if the raw MIDI velocity data is the same. If one track has maximum velocity, the other 1/2 of that velocity, there is likely your answer.

      Just shooting ideas. But it's all a process of elimination regardless. You need to systematically eliminate one piece of the puzzle at a time to isolate the item causing the problem. Then devise the solution.

      Comment


      • #4
        Thanks...excellent suggestion.
        Yamaha Birch Custom Absolute | Zildjian Ks

        Comment


        • #5
          Follow up to the points that Gastric made. I have noted the velocity differences between triggering with the TD-12 versus the Axiom 49 pads. The velocity is roughly a 1/3 to 1/2 less via the TD-12. This mirrors the volume difference I am seeing.

          So how do I make this adjustment to bring up the TD-12 MIDI velocity settings? Is this a global setting similar to a master volume? I want to make sure I am not altering the settings that would come out of the line outs of the TD-12, just MIDI.

          Thanks!
          Yamaha Birch Custom Absolute | Zildjian Ks

          Comment


          • #6
            Glad I could help. As far as raising MIDI velocities from your Roland module that's out of my area of experience. But for the Alesis modules I've owned that's controlled on a trigger-by-trigger basis by setting the GAIN so that the trigger itself is outputting MIDI Velocity = 127 (maximum) when striking the triggers the hardest. If you have GAIN set too low you can completely negate the ability to reach high/maximum velocities.

            I wouldn't be suprized if Roland had some more robust method to control overall kit gain.

            Comment


            • #7
              Thanks Gastric. I get the same thing whether I go direct from the TD-12 or via the MIDI mapper so something tells me it is the TD-12 that needs a changin'.

              Here's hoping that someone on the forum has some experience adjusting the MIDI velocity parameter on the TD's. My reading of the manual doesn't get me too far.
              Last edited by tripp2k; 07-09-08, 11:46 PM.
              Yamaha Birch Custom Absolute | Zildjian Ks

              Comment


              • #8
                Just to close this one out. I got frustrated with the silence I got here and other places and started getting back to redefining my favorite VEX set up and just playing. On a whim, I plugged MIDI back in and somehow I started getting more "volume" through MIDI. Not sure what changed, but happy with the exception of just a tiny bit of latency.

                Much appreciation to Gastric for chiming in. It forced me to go learn a bit more about MIDI and my TD-12. Nothing wrong about that.
                Yamaha Birch Custom Absolute | Zildjian Ks

                Comment

                Working...
                X