Announcement

Collapse
No announcement yet.

Drum Bass Double Trigger Issues - Resolve with Reaper / EZDrummer2?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Drum Bass Double Trigger Issues - Resolve with Reaper / EZDrummer2?

    Hi guys.

    I own a Roland TD1 kit and I am in the process to covert an acoustic kit. In the end, I will not use anything from the TD1, including the module.
    I am currently using a 22" bass drum and, as expected, I am having the double trigger issue. In the near future, I will buy a good module, but for now, I would like to address this issue as I have no choice but use the TD1 module.
    The TD1 has sensitivity settings only, so there is no way to change mask time or re-trigger cancel or any other parameter as far as I am aware of.

    I use Reaper and EZDrummer 2. Maybe SD3 on a later time. So I thought in using the applications to solve this issue until I buy a new module.

    Is there any way to manipulate mask time (preferable) on the Reaper or EZDrummer itself?

    I found a midi filter under JS. I heard about filtering based on velocity. Tried that on the specific midi note (C1), but I am not sure if I did it correctly as it had no effect.
    My main idea would be filtering the same note within the next 30ms after the first note was played. something similar to mask time, but anything is welcome.

    I am using the drumtec soft beater and a mesh head protector. I've already tighten the mesh head. I tried putting a pillow directly on the mesh head too. There was an improvement, but I am still getting double and sometimes triple notes.

    Any help is much appreciated.

    Thanks

    Ronaldo B.

  • #2
    Hi guys.

    It seems that I found what I am looking for, but I am still struggling to get it working.
    I found the plug in called MIDI Anti Flam.

    https://stash.reaper.fm/v/19119/MIDI_AntiFlam.zip

    This is the topic, for reference:
    https://forum.cockos.com/showthread....note+midi+time

    It blocks a given note for a certain amount of time, up to 1000ms.
    I am probably not setting this up correctly.

    VSTi works fine. I put all in a single track and single channel so I can rule out things.
    I have also put configured the C1 (36) note as this is the kick. With or without it, I still get no effect.

    Based on the screenshot, am I doing something wrong?




    I am trying to understand a bit more about plug ins and filtering MIDI as I strongly believe that I am doing something wrong on the basics.

    Cheers
    Ronaldo B.

    Comment


    • #3
      I think your best bet would be to get the bass drum damped and remove the problem at source.
      Roland TD30 module on TD20 kit SD3 with various kits. Pearl Masters Kit, Yamaha 9000RC original natural wood finish. Cymbals from Zildgian Pasite and Sabian. Loads of percussion bits. Cubase and Wavelab always current versions.

      Comment


      • #4
        Try loosening the batter head.... sometimes if a head is too tight is can cause the beater to bounce if you’re playing beater forward.
        Roland TD-30 & TM-6 Modules | Superior Drummer 3 on PC | Tama Superstar Hyper-Drive Maple A2E w/ R-Drums Triggers | ATV aD Cymbals | Axis Pedals | Tama & Gibraltar HW | Focusrite Clarett 4Pre | Simmons DA200S Monitor | V-MODA Crossfade M-100 OEMs & MEE MX4 PRO IEMs

        Comment


        • #5
          I think I got it. I need to reckon that I was stupid hehe...
          My problem was that it was applying the time based filter in all the notes even when selecting the specific channel (10 in my case) and specific note (36) under the Param button.
          I was doing it wrong.
          I didn't realize that the scroll bars are actually the notes (main panel) so it was just a matter to put the min and max notes in the 36 (note 36) and channel 10. Left the delay with 140ms. On a later time I will start from 30ms and I will keep testing until I don't hear the double/ghost notes.

          Regarding loosening the head, I will try it too so I don´t need to use a long time on the filter.
          It is already damped too, which helped a lot, but I was still getting double notes.


          Thanks again guys.
          Ronaldo B.

          Comment

          Working...
          X