Welcome! If this is your first visit, you will need to register to participate.

DO NOT use symbols in usernames. Doing so will result in an inability to sign in & post!

If you cannot sign in or post, please visit our vBulletin Talk section for answers to vBulletin related FAQs.

Announcement

Collapse
No announcement yet.

Is left channel on TD9 really mono?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Is left channel on TD9 really mono?

    I recently bought a powered speaker for my kit (Alto TS112A). When I use a single cable (plugged into the L/MONO jack of my TD9) the sound is so different from what I hear in the headphones -- much more distant and reverb-y. This leaves me wondering: am I really getting a mono signal vs. just one channel? Should I use 2 cables and pipe both channels into the speaker (it does have 2 inputs)?

    Please advise. Thanks!
    TD30 | PD-128S, PD-128, (2) PD-108, PD-120 | KD-120 | (2) CY15R, (2) CY14C, CY13R, CY12C, VH11 | MDS-25 rack | DW3000 double bass pedal | DW3000 HH stand | roc-n-soc nitro throne | Audio Technica ATH-M40x

  • #2
    You don't have anything plugged into R?

    (L is only mono if R is empty.)

    Bruce

    Comment


    • #3
      Thanks Bruce. That was my guess but wanted to double check. I guess I'll just have to adjust the sounds on the kit for when I'm playing through a speaker.
      TD30 | PD-128S, PD-128, (2) PD-108, PD-120 | KD-120 | (2) CY15R, (2) CY14C, CY13R, CY12C, VH11 | MDS-25 rack | DW3000 double bass pedal | DW3000 HH stand | roc-n-soc nitro throne | Audio Technica ATH-M40x

      Comment

      Working...
      X