Announcement

Collapse

Technical Posting Guidelines

TECHNICAL DISCUSSION ONLY! DO NOT POST LOUNGE OR PRODUCT DISCUSSION!

Having issues? Please visit our Forum Talk section for answers to frequently asked questions.

See more
See less

PD-120 rims not triggering

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Boingo
    replied
    You have aux 1 & 2. Must use piezo/fsr pads. Having said that, some have been rather creative in getting the rim portions to work. A guy named feefer has pioneered "shacking" and "holy grailing". It gets a bit deep. He's writing a "how-to" which might be out by Christmas.

    Leave a comment:


  • Big Jim
    replied
    Originally posted by Boingo:
    Hate to be the bearer of bad news, but they are not supposed to trigger. The PD-120 will only trigger the rim in the snare input. They have two piezo's and you need a piezo/fsr trigger to get dual functionality. Try a PD-9 in place of those PD-120 toms and you'll get a rim.

    Man that is not good news, the reason I bought the set I did was because the salesman said that all of the drums in the set would double trigger. I found out latter that the PD-100's would not but I thought all of the PD-120's would. So I guess I'll just have to use the snare,and cymballs to add sounds, Correct?


    [This message has been edited by Boingo (edited October 13, 2001).]

    Leave a comment:


  • Boingo
    replied
    Hate to be the bearer of bad news, but they are not supposed to trigger. The PD-120 will only trigger the rim in the snare input. They have two piezo's and you need a piezo/fsr trigger to get dual functionality. Try a PD-9 in place of those PD-120 toms and you'll get a rim.



    [This message has been edited by Boingo (edited October 13, 2001).]

    Leave a comment:


  • Big Jim
    started a topic PD-120 rims not triggering

    PD-120 rims not triggering

    Hello,
    My first time to post. I have a set of V-Pro concert drums, and I have not been able to get the 2 PD-120 rims to my right to trigger. My PD-120 Snare works fine head and rim, but the rims on the "floor" toms does not even light up the red rim light on my TD-10 module. I have stereo cable connected to both and pluged into the correct location. I have tried to edit some sound to the rims with no luck, I can use the module to select the rim, and assign a sound but when I hit it nothing. Any help would be appreciated.
Working...
X