Announcement

Collapse

Technical Posting Guidelines

TECHNICAL DISCUSSION ONLY! DO NOT POST LOUNGE OR PRODUCT DISCUSSION!

Having issues? Please visit our Forum Talk section for answers to frequently asked questions.

See more
See less

KD-8 intermittently cuts out

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • KD-8 intermittently cuts out

    I purchased a used KD-8 that seems to have some issues. It will work fine for weeks, then it will intermittently cut out for a while. This happens when it is connected to either a TD-3 or a TD-6, but I'm using the default settings so I don't know if that's an issue or not. When it does cut out, a couple of slightly harder than normal hits seems to cause it to work again for a minute or two, then it cuts out again. Then every once in a while, it will work fine for weeks (20+ hours). Any suggestions for fixing this problem would be greatly appreciated.

  • #2
    Sounds like a faulty internal connection either at the piezo sensor or output jack which would take some disassembly to track down, but have you tried a different cable?

    Bruce

    Comment


    • #3
      I swapped out the cable today, and so far so good. I won't know for sure for another month or so, but for now the problem seems gone. Thanks!

      Comment


      • #4
        Unfortunately, now it's doing it again with the new cable, so it looks like I need to take it apart. Are there any gotchas I need to know about before I disassemble the KD-8 or is it all straightforward?

        Comment


        • #5
          You may find Michael Render's details and photos useful: Rebuilding a Roland KD-8

          Bruce

          Comment

          Working...
          X