Announcement

Collapse

Technical Posting Guidelines

TECHNICAL DISCUSSION ONLY! DO NOT POST LOUNGE OR PRODUCT DISCUSSION!

Having issues? Please visit our Forum Talk section for answers to frequently asked questions.

See more
See less

TD-20 mix in sounds muddy

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • stickinthemud
    replied
    Ah, a computer! If it's a laptop, well, that's fairly typical. Personally I don't understand why you can get a perfectly good signal to a laptop's speakers, or even a set of headphones, but as soon as you plug it into a module it sounds like hammered you-know-what. I had the same issues trying to use my laptop that way.

    A desktop should be less prone to that, but the ultimate solution either way is a soundcard designed to put out a nice clean signal.

    Leave a comment:


  • SonOfBogMan
    replied
    Following up for the record now that holiday family stuff is over.

    Thanks for the suggestions. Trying a new audio source (a standalone mp3 player) sounded fine. So in my case it was not line levels or balance, but something specific to the computer I had driving the mix in - impedance, as this would explain why it sounded better for some devices than other.

    After listening to this thing a lot I've become pretty aware of some ground loopish 60hz noise going on, as well as a whine when the LCD monitor attached to the computer is on as well. I guess I need either isolation or give up on using that computer or sound card.

    Leave a comment:


  • stickinthemud
    replied
    I have not experienced any problems with the MIX IN. I have routed MP3 players and a sampler through it for monitoring and playback and have been perfectly happy with the sound quality. Are you sure all your cables are free of shorts and that your adapters and jacks are TRS (stereo, that is)? As Amonline suggested, your signal from your iPod may be turned up too high. Try bringing everything up little by little and see if that helps.

    You should not be having problems with this. In nothing plays well through this channel, you may have a defective module.

    Leave a comment:


  • Rewind
    replied
    I don't have it so I can just ask you to check if you are getting unbalanced -4dB or balanced +10dB signals to mix in. If mix in need balanced signals and what you have is unbalanced then of course it is going to be muddled with all the impedance differences etc, etc. =)

    I got the same thing with my TD-6V without investigating it further. Not exactly a quality sound interface on Mix In anyway.

    Leave a comment:


  • Alan VEX
    replied
    It really depends on what you feeding that input. I do not have the issues you have described. Sounds like you're feeding a hot signal. Regardless, I never thought the mix-in was design to truly "pass" audio. I think it is more designed for "monitoring". I'm most definitely sure that there's no super high class preamp there. The only tip I would suggest is backing down your source.

    Leave a comment:


  • SonOfBogMan
    started a topic TD-20 mix in sounds muddy

    TD-20 mix in sounds muddy

    I have a TD-20. I just bought a JBL eon15 G2 to gig with. Messing with this setup brought to my attention that any audio quality from the TD-20s mix-in is poor. Muddy.

    I use the mix-in to play along with music. When I connect a stereo source directly to the G2, it sounds good. But the same stereo source, when connected to the mix-in and passed through to either the master out or the headphones, sounds muddy. Sounds produced within the brain itself seem ok to my ear, on both the headphones and master out.

    Any tips? I know I can mix externally if it comes to that. I'm just surprised it works poorly, and would like to hear if other people have the same experience or if I'm unique.
Working...
X