Welcome! If this is your first visit, you will need to register to participate.

DO NOT use symbols in usernames. Doing so will result in an inability to sign in & post!

If you cannot sign in or post, please visit our vBulletin Talk section for answers to vBulletin related FAQs.

Announcement

Collapse
No announcement yet.

td-8 module lights up......is it because of the power supply I am using?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • BarT
    replied
    If your TD-8 will react to these buttons in its present state, then check the version with;

    1. Power on while holding the F1, F2, and F3 buttons until "Welcome to TD-8" shows in the display.

    2. Release the "F" buttons, and then press CLICK, followed by RIM.


    You could also see if it will react correctly to the start of the update procedure;

    2. Power on while holding [SETUP]+[REC], and you will enter Update Mode. [SETUP] will light.

    Full instructions for updating to version 1.10 are in a ReadMe.Txt file in the download; TD-8 System Update Version 1.10 (PC)


    Bruce

    Leave a comment:


  • blake41482
    replied
    How do I tell what is the version and how do I update? Could the version be causing conflicts? I replaced the battery and am wondering what could still be the problem

    PS: Thank you for answering my questions BART!

    Leave a comment:


  • BarT
    replied
    I would guess that power supply should be fine. Have you ever updated the firmware version on that TD-8? Now might be a good time to try.


    Bruce

    Leave a comment:


  • td-8 module lights up......is it because of the power supply I am using?

    td-8 module lights up at startup with all lights on and 88 on the number screen. I replaced the battery and it didnt fix the problem. I am wondering if it is because of the power supply. Can someone tell me if this is the correct working one or if they used this one?

    http://www.visualsound.net/1spot.htm

    ANy help would be appreciated
Working...
X