Announcement

Collapse

Technical Posting Guidelines

TECHNICAL DISCUSSION ONLY! DO NOT POST LOUNGE OR PRODUCT DISCUSSION!

Having issues? Please visit our Forum Talk section for answers to frequently asked questions.

See more
See less

Mimic Pro June 2020 Library Update Help Needed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mimic Pro June 2020 Library Update Help Needed

    Hi Everyone -
    I have been trying to update my Pearl Mimic Pro for a few days now and at this point I'm reaching out for some help.
    I have done updates on the Mimic and am very familiar with the process. However,
    I have followed the steps carefully -- and all has been good until I try to load the new library into the Mimic via the USB drive.
    It starts fine and progresses normally but then when it gets to about 80% it suddenly just exists the update screen unfinished, going back to the "Home" screen. I have tried reinstalling the library a few times now and this is where I'm stuck.
    Helpful Info: Newly formatted 32 GB USB drive formatted on MIMIC before using for update; Using Windows 10 64 bit machine for downloading.
    Any ideas? Thanks in advance!

  • #2
    Have you checked the library to ensure it's not installed? Run the integrity check.
    Alan
    ---------------------------------------------------------------------------------------------------------
    website | youtube | facebook | group | newsletter | message | recommendations

    Comment


    • #3
      If you see no error on integrity check, and you have DRW CLT 8" to 16" blue toms, + all bow articulation on cymbal, you are fine..
      Last edited by Chris K; 07-08-20, 11:48 AM.

      Comment


      • #4
        Originally posted by Barry2020 View Post
        Hi Everyone -
        It starts fine and progresses normally but then when it gets to about 80% it suddenly just exists the update screen unfinished, going back to the "Home" screen. I have tried reinstalling the library a few times now and this is where I'm stuck.
        I have the same experience, don't worry, as Chris said:"DRW CLT 8" to 16" blue toms, + all bow articulation on cymbal" everything is fine.

        Comment


        • #5
          Thanks for the replies.
          After using a new 32 GB stick and re-downloading the sound files with no success, I thought maybe first I should try deleting the current sound library, then installing the new one. Yes....it worked!
          It was little scary doing it that way, since I was thinking maybe something is corrupt in the system and I won't be able to install any new Mimic libraries. Turned out it worker great! I deleted the already installed Mimic Library, then install the new library.
          I now have the newly updated sound library. If anyone is having a similar issue with the new library install this may be an option.

          Comment


          • #6
            Also, I just noticed this morning that there was a newly released software update in addition to the new sound library.
            I installed that update, then did the sound library, so I'm not sure what the real reason for the hiccup was.
            In any event, thanks to this great community, I have learned a lot over the years from it but never posted until now

            Comment

            Working...
            X