Announcement

Collapse

Technical Posting Guidelines

TECHNICAL DISCUSSION ONLY! DO NOT POST GENERAL E-DRUMMING OR GENERAL PRODUCT QUESTIONS!
See more
See less

Mimic Pro No Triggering Sounds

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Mimic Pro No Triggering Sounds

    Greetings!

    Hi to all! I have been blessed to save to acquire my own Mimic Pro Module.

    I have used this great module with a friend before and it was so nice. Now, the great day arrive to have my own. Thing is, when I plug the 7-14 pin connector (from my old Roland TD11 module) there are no sounds whenever I hit the pads.

    Secondly, as another option I tried to use a typical balanced 1/4 TRS cable, plugged it directly to snare output to my Roland PD-128 (as I have 2 extra cables lying around) to test with the snare and still I get no triggering sounds whenever I hit the pad.

    There are no movement on the trigger bar (with red, yellow and blue lines) whenever I hit a pad in these 2 cable arrangements/connectors.

    Are there anything I am missing with setting this up?

    Hope you can help me, my brothers.

    God bless y'all

    JC

  • #2
    Originally posted by josecarlo1129 View Post
    Greetings!

    Hi to all! I have been blessed to save to acquire my own Mimic Pro Module.

    I have used this great module with a friend before and it was so nice. Now, the great day arrive to have my own. Thing is, when I plug the 7-14 pin connector (from my old Roland TD11 module) there are no sounds whenever I hit the pads.

    Secondly, as another option I tried to use a typical balanced 1/4 TRS cable, plugged it directly to snare output to my Roland PD-128 (as I have 2 extra cables lying around) to test with the snare and still I get no triggering sounds whenever I hit the pad.

    There are no movement on the trigger bar (with red, yellow and blue lines) whenever I hit a pad in these 2 cable arrangements/connectors.


    JC
    Warning, DB25 are not for triggers, but sound audio output.

    See if the firmware is v1.0.9 at setting\sys if not update to the latest http://pearl-electronics-support.com...les/mimic-pro/

    Also strongly recommended to do reset at setting\sys click reset.

    some tutorial
    https://www.youtube.com/user/PearlMu...ry=pearl+mimic

    Read Manual http://pearl-electronics-support.com...l_v1.0.9-1.pdf
    Last edited by Chris K; 01-16-20, 03:12 AM.

    Comment


    • #3
      Originally posted by Chris K View Post

      Warning, DB25 are not for triggers, but sound audio output.

      See if the firmware is v1.0.9 at setting\sys if not update to the latest http://pearl-electronics-support.com...les/mimic-pro/

      Also strongly recommended to do reset at setting\sys click reset.

      some tutorial
      https://www.youtube.com/user/PearlMu...ry=pearl+mimic

      Read Manual http://pearl-electronics-support.com...l_v1.0.9-1.pdf

      Woah, did a lot of studying and research about this module and I miss this info about 7-14 pin connector reason I seek the expertise of this forum about it.

      Thank you, sir for this. Yeah my module is up to the latest firmware. I will try again to check later using my spare TRS 1/4 cable if there will be signal or it will trigger and update you.

      many thanks,
      JC

      Comment

      Working...
      X