Announcement

Collapse

Technical Posting Guidelines

PLAYING TECHNIQUE DISCUSSION ONLY! DO NOT POST TECHNICAL QUESTIONS!
See more
See less

Roland CY-8 Double Zone Problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Roland CY-8 Double Zone Problem

    My CY-8 sometimes works and sometimes not... I tried a couple of times to disconnect and connecting the switch and was working but now looks like a luck to works.

    I read before CY-8 is trash but is the first time happens to me.

  • #2
    search in this forum pixie dust, i think, people took them apart and clean inside.... if not, check the piezo connections.

    Comment


    • #3
      Between my kit and my sons I have three of them. One of mine has problems also. Is it just the edge switch on yours? Mine is the top piezo which is intermittent. I have a bag full of piezo’s the same size so I intend to take it apart when I can be bothered. It may just be a wire but I bought the bag for a few projects I fancy having a go at.
      Roland TD30 module on TD20 kit SD3 with various kits. Pearl Masters Kit, Yamaha 9000RC original natural wood finish. Cymbals from Zildgian Pasite and Sabian. Loads of percussion bits. Cubase and Wavelab always current versions.

      Comment


      • #4
        If the cymbal doesn’t choke then that’s the pixie dust issue and you’ll need open up the edge and clean the green ribbon inside the edge of the cymbal and clean out the debris. While you’re in there, you might as well replace the piezo. Good luck!
        Equipment: TD-30KV, DW9000 hardware, ROC-N-SOC Throne, Behringer ULTRATONE K3000FX Amp, JBL EON 615 Powered Speaker, Yamaha MG06X. 1965 Ludwig Super Classic. Black diamond pearl. Zildjian K Custom Dark cymbals, DW 7000 hardware, DW 9000 kick pedal.

        Comment


        • #5
          jimorlando thank you! now is working great.

          mkok yes it was only the edge.

          Comment

          Working...
          X