Announcement

Collapse

Technical Posting Guidelines

TECHNICAL DISCUSSION ONLY! DO NOT POST LOUNGE OR PRODUCT DISCUSSION!

Having issues? Please visit our Forum Talk section for answers to frequently asked questions.

See more
See less

Sound issues/glitchs with Pearl Mimic Pro

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Sound issues/glitchs with Pearl Mimic Pro

    Hello everyone,

    A couple of weeks ago, during my practice, the sound began to twitch and disappear unpredictably.

    This effect could be easily caught just after module reboot/start, it sounds like the module tries to load all samples/waves/layers and slows down during the 10-30 sec after a restart. And if I play randomly, with good dynamics, the effect goes away for some time but it unpredictably returns during the playing.

    Attached ( mimic-sound-issue.wav ) the recorded audio where sound interrupts/twitches/glitches unpredictably. The first glitch - between 3 and 4 sec (tom sound interrupted after rim shot), 5th second - tom sound interrupted harshly, 7th second - crash sound interrupted (8th second - replayed correctly).

    I think that most likely Mimic issue, not pads since such glitches are unpredictably appearing, and it doesn't matter which pad I used.

    I reset all settings to the factory ones, set up all pads again but it does not help.

    According to Pearl's warranty, I have to contact the dealer in this case, I sent an email to them but it wouldn't be a fast solution, I suppose: I'm from Russia and the dealer is Drum-Tec, Germany.

    So maybe someone had a deal with such case? What could be the problem?
    Thanks in advance, any thoughts, ideas are welcome.

  • #2
    It's SSD defect, there is recall for these unit with faulty SSD from Pearl. You will need to deal with your store policy for exchange.

    Comment

    Working...
    X