Welcome! If this is your first visit, you will need to register to participate.

DO NOT use symbols in usernames. Doing so will result in an inability to sign in & post!

If you cannot sign in or post, please visit our Forum Talk section for answers to frequently asked questions.

Announcement

Collapse
No announcement yet.

Snare problem

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Snare problem

    Does anybody have trouble with the rim of the snare triggering when trying to hit the head? I've got mine setup with a snare sound on the head and a side stick sound on the rim. Sometimes when I try to hit the head, the rim triggers. It's done this with all three of my pd-120s. Is it a problem w/the brain, or am I just hitting the rim?

  • #2

    I had the same problem and gave up on the crossstick sound... I now have the standard... My snare head is set to a snare sound and the rim set to the same type snare's rim sound. So I get a tastey crack when I do a rim shot...

    BTW, I have the TD-10 with TDW-1 expansion card.
    My Hart Dynamics GigaPro (vintage 1999)

    Comment


    • #3
      I get the idea you have not got the expansion? Try lowering the rim sensitivity. Its adjusted on the options page of the trigger screen.

      Comment


      • #4
        Originally posted by BtnkBndt:
        I get the idea you have not got the expansion? Try lowering the rim sensitivity. Its adjusted on the options page of the trigger screen.
        BtnkBndt, no I don't have the expansion card. I wish I did, but school comes first. I tryed adusting the rim sesitivity and it fixed it.

        Thanks,
        Raffy85

        Comment

        Working...
        X