Announcement

Collapse
No announcement yet.

TD11 Mount - how do i connect it? (photo included)

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • TD11 Mount - how do i connect it? (photo included)

    hello
    i just got the td11 and the mount.
    im trying to connect the mount but the 2 parts cant be connect each other

  • #2
    Download this "TD-11 Setup Guide": http://cdn.roland.com/assets/media/pdf/TD-11K_OM.pdf

    Then on the first page, in upper right-hand corner, there is a little diagram showing how to attach one of the parts from your picture to the drum module:
    TD11-mount.png

    Then insert it into the other part which is supposed to be attached on the rack.
    Last edited by RandyD; 10-10-17, 04:59 PM.
    My e-kit, photos and details

    Comment


    • #3
      i'm guessing the mount doesn't fit in the clamp ? if so.. (also check all other clamps..)
      you could buy a (used) standard gibraltar clamp https://images-na.ssl-images-amazon....YL._SX355_.jpg which would always fit ..
      Last edited by Ericdrumz; 10-11-17, 03:24 AM.

      Comment


      • #4
        The clamp on the photo looks ok to me. The drum module mounted on the mounting plate should fit into the smaller tube with inner grooves on the clamp.
        My e-kit, photos and details

        Comment


        • #5
          i cant mount the module into the clamp.
          what about the MDH-10 ? that should work ?

          Comment


          • #6
            I'm not sure how MDH-10 would help. What is the problem exactly? You cannot attach the mounting plate to the drum module with 2 screws? Or you cannot insert the mounting plate tube to the clamp?

            image_31245_modified.jpg
            Last edited by RandyD; 10-12-17, 04:48 PM.
            My e-kit, photos and details

            Comment


            • #7
              Originally posted by RandyD View Post
              I'm not sure how MDH-10 would help. What is the problem exactly? You cannot attach the mounting plate to the drum module with 2 screws? Or you cannot insert the mounting plate tube to the clamp?

              image_31245_modified.jpg
              i cant insert the mounting plate tube to the clamp..its looks like the clamp is smaller than the tube size...

              Comment


              • #8
                I had a Alesis clamp like that. Force that sucker open enough (what I did) or get a new one not alesis.
                "It makes sense if you dont think about it"

                Mimic Pro, SPD-SX, 2-QSC K-10s, K-sub, Yamaha mixer, and a bunch of other expensive cool things!

                Comment

                Working...
                X