Announcement

Collapse

Technical Posting Guidelines

TECHNICAL DISCUSSION ONLY! DO NOT POST LOUNGE OR PRODUCT DISCUSSION!

Having issues? Please visit our Forum Talk section for answers to frequently asked questions.

See more
See less

Cymbals setting...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cymbals setting...

    Hi all,

    I have a question regarding cymbal settings. I'm playing an v-pro kit w/expansion board and I noticed after hearing a recording last night, that my cymbals just don't have very good resonance. They seem to be cutting off, especially on the crashes. Does someone have some setting suggestions I could try? I love the expansion board. It's really improved the sound, but I haven't really spent the time tweakin'settings. I'd also be interested in hearing suggestions for hh and rides also.

    THanks!

    Chris

  • #2
    Originally posted by cproctor:
    Hi all,

    I have a question regarding cymbal settings. I'm playing an v-pro kit w/expansion board and I noticed after hearing a recording last night, that my cymbals just don't have very good resonance. They seem to be cutting off, especially on the crashes. Does someone have some setting suggestions I could try? I love the expansion board. It's really improved the sound, but I haven't really spent the time tweakin'settings. I'd also be interested in hearing suggestions for hh and rides also.

    THanks!

    Chris
    Have you adjusted the delay setting? Try a setting of 3 or more and see if it's to your liking. I have found that the cymbals by themselves never seem to have that sound I'm looking for, but when you mix your kit with the rest of the band they do quite well. Also play with ambience and effects.
    Kit Pic 1 Kit Pic 2 Kit Pic 3... And FOR SALE I have: 3 PD-9's, MDS-10 purple rack w/cables/pad and cym mounts. See classified posts for details or PM me.

    Comment


    • #3
      Thanks, Boingo, I'll just play with them tonite.

      Comment

      Working...
      X