Welcome! If this is your first visit, you will need to register to participate.

DO NOT use symbols in usernames. Doing so will result in an inability to sign in & post!

If you cannot sign in or post, please visit our Forum Talk section for answers to frequently asked questions.

Announcement

Collapse
No announcement yet.

Focusrite 2i2 need help

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Focusrite 2i2 need help

    Not sure if anyone can help here, but any suggestion is welcome. My audio interface (a USB powered Focusrite 2i2) turns on (when connected by USB), and the computer says "This device is working properly," but it has stopped picking up signals from my TD-11 module (i.e. no green/red indicator lights around the inputs) and producing sound. Changed cables, same thing. Tried it on another computer, same thing, even with updated drivers. Anything I should be trying?
    Roland TD-11: PD-105 snare, PDX-100 toms (3); CY-13R ride; CY-12 crash (2); KD-9 kick; Iron Cobra HP900 kick pedal; VH-10 hi-hat; Iron Cobra HH605 hi-hat stand; Simmons DA200s monitor; Sony MDR-7520 and Audioquest Nightowl headphones; AD2; VEX Apex, Sync, Icons, Boost, Masters 1-2; Drum-Tec LA Studios, Real Acoustic, Alternate Rock Sound Editions

  • #2
    Are you connecting your drums to the Focusrite though Midi? If so then I've had some issues before as a result of me messing around with my module MIDI settings (I think changing the clock sometimes caused an issue, although I'm not sure why it would). I really can't remember the details, but a factory reset of the module fixed it....

    If you've got any other MIDI instruments lying around (on old keyboard maybe) then it might be worth giving that a go too.

    Comment


    • #3
      if all else fails, I had extremely excellent customer support from Focusrite getting my Scarlett working.

      Comment


      • #4
        If using a pc be sure and go into the device manager, scroll to the bottom and find USB hubs, right click on all of them and make sure the box is unchecked that says something like turn these ports off to save power. The pc will turn off power to some USB ports when it feels the need. Just a thought.

        Comment


        • #5
          Thanks for the tips. Philo: I am connecting it via 1/4" cable (also tried xlr). tav: the usb port is live (the green light is on, on the Focusrite). Chasmanian: I did contact them, and they said if there are no green lights around the inport ports then it is a hardware failure. So that seems to be that. Except that it's still under warranty.....so just checking out that side of it. Thanks.
          Roland TD-11: PD-105 snare, PDX-100 toms (3); CY-13R ride; CY-12 crash (2); KD-9 kick; Iron Cobra HP900 kick pedal; VH-10 hi-hat; Iron Cobra HH605 hi-hat stand; Simmons DA200s monitor; Sony MDR-7520 and Audioquest Nightowl headphones; AD2; VEX Apex, Sync, Icons, Boost, Masters 1-2; Drum-Tec LA Studios, Real Acoustic, Alternate Rock Sound Editions

          Comment


          • #6
            Having a hardware failure is a bummer. But being under warranty is nice, if not a bother.

            Let me get this straight... you have 1/4" going out of the module to the Focusrite, then, USB into the computer to record it all, right?

            Can you confirm that your module is sending audio out? Perhaps just connecting the output of the module to the line input of your computer directly?
            Perhaps you have a mic, or some form of audio you could try with the Focusrite interface, other than the module?

            With computer audio, there are so many factors to take into account... from cables to audio drivers and settings...
            DTX700, eDRUMin 4+10, A2E Dixon kit, Yamaha cymbals, FSR HH
            Kit Pix http://vdrums.com/forum/album.php?albumid=613

            My new venture, HiEnd Speakers. : voglosounds.com

            Comment


            • #7
              So Gradier – I don’t mean to hijack your thread here. If you wish, we can run this under a separate post.

              I too was running a Focusrite 2i2 with my TD-11 via USB (HP laptop, i5, 8GB RAM SSD). I did have it running but it was not what I expected. I was hoping to drastically reduce (if not eliminate) the latency when playing VST (Addictive Drums 2, BFDeco). I really can’t say I noticed any major improvement over simply running through the TD-11 module as ASIO. The latency value with the 2i2 is quite small and for the most part you probably can’t even hear it, but I can sense it. When comparing VST sounds to those coming directly from the module, there was a “feeling” of latency. This is why currently I’m running VEX kits (sometimes overlaid with AD2).

              Also, when running the 2i2, I could not listen to music (Spotify, MP3’s) at the same time. I believe this had something to do with the ASIO driver. Did or do you “play along” or simply as VST drumming?

              Comment


              • #8
                I don't know much about much.
                but if its any help:
                I hook my TD 15 to my laptop.
                also hook the Focusrite Scarlett to the laptop.
                all USB.
                and then configure it to have SD2 control the TD 15.
                the drivers are the ASIO Roland drivers.
                I can add external audio by connecting to the Scarlett's input 1.

                Comment


                • #9
                  I don't know much about much.
                  but if its any help:
                  I hook my TD 15 to my laptop.
                  also hook the Focusrite Scarlett to the laptop.
                  all USB.
                  and then configure it to have SD2 control the TD 15.
                  the drivers are the ASIO Roland drivers.
                  I can add external audio by connecting to the Scarlett's input 1.

                  Comment


                  • #10
                    Thanks again for the advice. Perceval; yes it's 1/4" out to the Focusrite and USB from the computer. The module is sending out (checked this by going direct to speakers) EssKayKay: I was playing AD2 along with my Itunes tracks; everything worked fine through ASIO and latency was not an issue. The Focusrite technician was helpful...said that no green colour around the inputs means hardware failure. Now I have hooked up, in the interim, my Xenyx 802. Running ASIO trough the TD-11. So far so good, except that the Xenyx 802 won't allow me to play with/without sound from the monitors. There is a button ("2 TR to CTRL Room") but instead of turning the monitors on and off, it turns the headphones on and off. So, I can play 1. headphones with monitors (which I like) or 2. just monitors, but not just headphones (obvious a need late at night).
                    Roland TD-11: PD-105 snare, PDX-100 toms (3); CY-13R ride; CY-12 crash (2); KD-9 kick; Iron Cobra HP900 kick pedal; VH-10 hi-hat; Iron Cobra HH605 hi-hat stand; Simmons DA200s monitor; Sony MDR-7520 and Audioquest Nightowl headphones; AD2; VEX Apex, Sync, Icons, Boost, Masters 1-2; Drum-Tec LA Studios, Real Acoustic, Alternate Rock Sound Editions

                    Comment


                    • #11
                      Thanks Gradier - I too am running this through a Xenyx mixer (albeit a 502). This may sound weird but like I said, I use VEX and AD2 concurrently. It's like I get the zero latency from VEX and the sound from AD2 -- maybe just my picayune nature.

                      Thanks again.....

                      Comment


                      • #12
                        Funnily enough, I run them together sometimes too, so I know what you're getting at.
                        Roland TD-11: PD-105 snare, PDX-100 toms (3); CY-13R ride; CY-12 crash (2); KD-9 kick; Iron Cobra HP900 kick pedal; VH-10 hi-hat; Iron Cobra HH605 hi-hat stand; Simmons DA200s monitor; Sony MDR-7520 and Audioquest Nightowl headphones; AD2; VEX Apex, Sync, Icons, Boost, Masters 1-2; Drum-Tec LA Studios, Real Acoustic, Alternate Rock Sound Editions

                        Comment

                        Working...
                        X