Welcome! If this is your first visit, you will need to register to participate.

DO NOT use symbols in usernames. Doing so will result in an inability to sign in & post!

If you cannot sign in or post, please visit our Forum Talk section for answers to frequently asked questions.

Announcement

Collapse
No announcement yet.

td-20 triggering

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • td-20 triggering

    HELP!!!! Was wondering if anyone can help me. My 2nd tom when the head is struck it immediately triggers to rim..Not sure what this is. It also says POSI which im not sure what that is either..Any help you gurus can give me will be greatly appreciated..Thank you in advance
    TD-20, TD-8, PD-105 X3, PD-125 X 1 , KD-125, MDS-20, CY-12 C/R, PD-6 X4, VH-12, PCY-135, PCY-155...AXIS BASS DRUM PEDAL...COBRA HH STAND...............Vex'd Out To The Max Drummers Dream

  • #2
    The pad is is a pd 105 .....sorry
    TD-20, TD-8, PD-105 X3, PD-125 X 1 , KD-125, MDS-20, CY-12 C/R, PD-6 X4, VH-12, PCY-135, PCY-155...AXIS BASS DRUM PEDAL...COBRA HH STAND...............Vex'd Out To The Max Drummers Dream

    Comment


    • #3
      Just a rim sound or does the RIM button light up too?

      All kits or only one?

      Bruce

      Comment


      • #4
        The rim button lights up. On all kits. And it also says posi. Not sure what that means either. Any help will be greatly appreciated
        TD-20, TD-8, PD-105 X3, PD-125 X 1 , KD-125, MDS-20, CY-12 C/R, PD-6 X4, VH-12, PCY-135, PCY-155...AXIS BASS DRUM PEDAL...COBRA HH STAND...............Vex'd Out To The Max Drummers Dream

        Comment


        • #5
          Check the cable at both ends, and that it's a stereo TRS cable.

          POSI, which just means Positional Sensing, is normal for a tom rim (see bottom left of Page 32 in the TD-20 manual).

          Comment


          • #6
            Got it working but it seems to be backwards. still saying rim when i hit the head on different kits..just changed the tom to to t2r and t2. and it seems to work. Not sure why. but its working any more suggestions . Thank You in advance
            TD-20, TD-8, PD-105 X3, PD-125 X 1 , KD-125, MDS-20, CY-12 C/R, PD-6 X4, VH-12, PCY-135, PCY-155...AXIS BASS DRUM PEDAL...COBRA HH STAND...............Vex'd Out To The Max Drummers Dream

            Comment


            • #7
              Try swapping the Tom 1 and Tom 2 cables at the drums to see if it's a module or pad issue.

              Then swap those cables at the module end too to see if it's a defective cable.

              If the problem moves it may help you work out what's causing it.

              Bruce

              Comment


              • #8
                thanks again for all your help
                TD-20, TD-8, PD-105 X3, PD-125 X 1 , KD-125, MDS-20, CY-12 C/R, PD-6 X4, VH-12, PCY-135, PCY-155...AXIS BASS DRUM PEDAL...COBRA HH STAND...............Vex'd Out To The Max Drummers Dream

                Comment


                • #9
                  Definately still does it when I switch kits not sure if the module is going but leaving it on 1 set for now have a show coming up and dont want to have problems with that..
                  TD-20, TD-8, PD-105 X3, PD-125 X 1 , KD-125, MDS-20, CY-12 C/R, PD-6 X4, VH-12, PCY-135, PCY-155...AXIS BASS DRUM PEDAL...COBRA HH STAND...............Vex'd Out To The Max Drummers Dream

                  Comment

                  Working...
                  X