Announcement

Collapse
No announcement yet.

Display TD-20 display repair

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • ehudg2000
    replied
    Thanks, Lorin.

    I did clean the ribbon flat connector, but that did nothing. After reading your post, I realized that there were these two internal thin flat connectors, and when I cleaned these, per yur post, all was fixed. It took me all of 20 minutes, and it was done.

    Thanks for the detailed post from the past; Still fresh as in the day it was written... ;o)
    You saved me, buddy.

    Udi

    Leave a comment:


  • mkok
    replied
    Originally posted by rentadrummer View Post
    I bookmarked this thread several weeks ago in case I ever needed to do a screen repair, and now it seems I might. The screen still works, but I'm noticing that it needs an occasional brightness adjustment, which it's never needed in the past.

    I found this recently posted video on YouTube that shows a much simpler repair process, without the need to remove any of the boards.

    https://www.youtube.com/watch?v=sWRVaHOrjAc

    Does this accomplish the same thing, or is it not as complete as the original version posted above?
    This may well work depending on where the problem is. Mine was the whole screen fading and getting progressively worse. He is showing a single connector but there is also a connector going into the screen board which he does not touch. Once you have the back off you may as well do all the connectors. Taking a shortcut means you may have to do it again anyway.

    Leave a comment:


  • rentadrummer
    replied
    I bookmarked this thread several weeks ago in case I ever needed to do a screen repair, and now it seems I might. The screen still works, but I'm noticing that it needs an occasional brightness adjustment, which it's never needed in the past.

    I found this recently posted video on YouTube that shows a much simpler repair process, without the need to remove any of the boards.

    https://www.youtube.com/watch?v=sWRVaHOrjAc

    Does this accomplish the same thing, or is it not as complete as the original version posted above?

    Leave a comment:


  • 2pods
    replied
    Would the repair on a TD12 be much different ?

    Having foolishly sold my TD12 a few years ago, I have a TD11 on which I'm missing the trigger set up stuff (as I seem to have a "soft PD85 trigger, but that's another story or post), so I'm seeing TD12s for about £350-£400 but worry the screen thing will happen

    Leave a comment:


  • DrumKnut
    replied
    Originally posted by Rh1464 View Post
    Hi everyone.

    This thread is spot on for what I need! Ive got as far as opening it up and trying to remove the ribbon cables from the main board, but that is where I am currently struggling at the moment. From the pictures above, I can see that it is just the ribbon that should release from the black connector soldered to the board. However, despite a bit of encouragement, the cables seem reluctant to come out. Is there a knack, or does it take more force that Iím currently brave enough to use?

    Any help would be much appreciated,

    cheers,

    rob
    BTW, label and place the screws in different cups when taking apart, snap a pic prior to removing each board. Some are slightly different, so this makes it easier to re-assemble.

    Leave a comment:


  • DrumKnut
    replied
    Originally posted by Rh1464 View Post
    Hi everyone.

    This thread is spot on for what I need! Ive got as far as opening it up and trying to remove the ribbon cables from the main board, but that is where I am currently struggling at the moment. From the pictures above, I can see that it is just the ribbon that should release from the black connector soldered to the board. However, despite a bit of encouragement, the cables seem reluctant to come out. Is there a knack, or does it take more force that Iím currently brave enough to use?

    Any help would be much appreciated,

    cheers,

    rob
    It is just the cables that come out. But it does take a bit of effort. What I did was grab them by the each edge, one edge at a time, and pulled slightly. Then went to the other edge and did the same. See-saw them back and forth until they came out. I did the same in inserting them back in with my fingers close to the connector. They are so wide I am afraid you will bend them if you try to do it by holding in the middle and just pulling/pushing.

    Leave a comment:


  • Rh1464
    replied
    Hi everyone.

    This thread is spot on for what I need! Ive got as far as opening it up and trying to remove the ribbon cables from the main board, but that is where I am currently struggling at the moment. From the pictures above, I can see that it is just the ribbon that should release from the black connector soldered to the board. However, despite a bit of encouragement, the cables seem reluctant to come out. Is there a knack, or does it take more force that Iím currently brave enough to use?

    Any help would be much appreciated,

    cheers,

    rob

    Leave a comment:


  • DrumKnut
    replied
    A few years of this messed up display was frustrating for my TD20 at home. Had it for 13 yrs. Was really grateful to find this post. Followed it, and it all looks brand new. Worked GREAT!
    Couple things I did additionally was use CRC electronics cleaner and a Q-Tip to clean ALL of the contacts instead of just the display (use tight wound Q-tips, lightly spray the cleaner into a glass cup to puddle the cleaner). Might as well get all of the corrosion off even if not too visible. Also changed the backup battery while I was in there. Very happy with the results. Was gonna get the TD50 upgrade kit before doing this, saved enough to get an Octapad and still save $2k. May grab some Expressions now to get some newness to the sounds.

    Leave a comment:


  • lpotamianos
    replied
    Had this problem for a couple of years and finally got the courage to do the 'repair'
    Photo 28-05-2019, 16 48 42.jpg

    I removed all bottom screws, connectors for the board, removed the board
    Photo 28-05-2019, 16 49 47.jpg

    Then removed screws from the back and removed the drum connector boards,

    Photo 28-05-2019, 16 54 01.jpg

    I begun unscrewing the power supply board, but then realized I could do it without removing it. Then I pulled the connectors as described in the post (the picture shows the small connector open), pulled the ribbons, and reseated them. They did not seem to have any problem at all, no corrosion, no anything, which worried me because I thought that my problem would be different.

    Photo 28-05-2019, 17 01 02.jpg


    I put everything back together and rushed to turn it on to see what happened, and bingo! The screen is like new! Unfortunately I did not take a photo before, but it was exactly like videos in Youtube: half the screen was blinking, parts were becoming black, and after a few minutes you could not read anything on the screen.

    Photo 28-05-2019, 17 35 35.jpg

    Leave a comment:


  • RuskinFred
    replied
    Followed the procedure, my display is back to normal. Thank you!

    Leave a comment:


  • rsanto
    replied
    Worked for me! Thanks Loris!

    Leave a comment:


  • Coster
    replied
    Great info! Just found this post after having discovered the same some weeks ago and applied. the fix. For those who still have issues after this procedure, you might go one step further.
    take some sharp scissors and cut of 1mm of the displays flat cable(s). This will create a 'new' point of contact between the connector and the conductive material on the flat cable. I have solved many issues in my time as repair technician in the consumer electronics branche, all related to this cable connector combination. The scissor method always worked.
    regards,
    Ed

    Leave a comment:


  • mkok
    replied
    Still fixing for people. Eventually got round to doing this on my sons td20 and as good as new. I did use a alcohol wipe to make sure and used it on all the other connectors as well. This thread just keeps on giving. Really appreciated. Thanks

    Leave a comment:


  • Fat Rich
    replied
    Fantastic post, have been struggling with an almost completely dead lcd pretty much since the module went out of warranty. Got a quote from Roland about 10 years ago to fix and it was about £300..... no thanks!

    Stumbled across this thread yesterday, pulled my module apart this morning and half an hour later it's as good as new

    Huge thank you, an unexpected Christmas gift, I owe you a beer (or 10)

    Leave a comment:


  • chandler76
    replied
    Almost 5 years later and this is still helping people fix their LED displays. Thanks very much.

    Leave a comment:

Working...
X