Announcement

Collapse
No announcement yet.

Repair on a PD-120?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Repair on a PD-120?

    I've got a PD-120 that's not triggering well at all. If you smack it really hard dead on the cone, it will trigger, but anywhere else and there's nothing. Is that an indication that piezo needs to be replaced or something else?

    Thanks!
    TD-20, TD-6V, Hart Pro Snare, PD-80, PD-100 x2, PD-120 Toms, Hart II E Ride, 13" Crash, Jman 16" Crash, 18" China, 12 &10 inch DIY Splash, CY-5 splash, VH-11 hihat w/ Iron Cobra Stand, 2 KD-8 w/ Pearl Eliminator pedals.

  • #2
    It's more likely that the cone needs to be replaced: Does this cone need replaced?

    Bruce

    Comment


    • #3
      That could be....

      Is there usually visable deteriation on the cone, or can they look good and still be going bad?
      TD-20, TD-6V, Hart Pro Snare, PD-80, PD-100 x2, PD-120 Toms, Hart II E Ride, 13" Crash, Jman 16" Crash, 18" China, 12 &10 inch DIY Splash, CY-5 splash, VH-11 hihat w/ Iron Cobra Stand, 2 KD-8 w/ Pearl Eliminator pedals.

      Comment


      • #4
        Usually it is visible, also is the head nice and tight? Sometimes if it is loose it won't trigger good.

        Comment


        • #5
          They head is tight, the cone looks ok. It actually came back and started working right, it makes me think something besides the cone is wrong. I suspect wiring or the piezo, but I've never seen the effects of a piezo going bad, so it's just a guess.
          TD-20, TD-6V, Hart Pro Snare, PD-80, PD-100 x2, PD-120 Toms, Hart II E Ride, 13" Crash, Jman 16" Crash, 18" China, 12 &10 inch DIY Splash, CY-5 splash, VH-11 hihat w/ Iron Cobra Stand, 2 KD-8 w/ Pearl Eliminator pedals.

          Comment


          • #6
            Tried a different cable?

            Bruce

            Comment


            • #7
              Yup. I switched it with a different tom's cable and got the same issue with the pad, I'm kind of confused now.
              TD-20, TD-6V, Hart Pro Snare, PD-80, PD-100 x2, PD-120 Toms, Hart II E Ride, 13" Crash, Jman 16" Crash, 18" China, 12 &10 inch DIY Splash, CY-5 splash, VH-11 hihat w/ Iron Cobra Stand, 2 KD-8 w/ Pearl Eliminator pedals.

              Comment


              • #8
                Have you been able to check the wire connections to the piezo?

                Replacing cone and piezo has solved triggering issues on a PD-120 before now, e.g.: TD-20 Intermittent Snare Problem

                Bruce

                Comment


                • #9
                  No, I can't actually see the connections to the piezo 'cause the cone's in the way. I can replace them both and see if that fixes it.
                  TD-20, TD-6V, Hart Pro Snare, PD-80, PD-100 x2, PD-120 Toms, Hart II E Ride, 13" Crash, Jman 16" Crash, 18" China, 12 &10 inch DIY Splash, CY-5 splash, VH-11 hihat w/ Iron Cobra Stand, 2 KD-8 w/ Pearl Eliminator pedals.

                  Comment

                  Working...
                  X